Unusual DX error (computer resets)
Amrazek This is a most strange error that I have been getting for the last 2 days(I upgraded my system lately). It is this: my computer simply resets when I run DX from the VB IDE. Strange, yes? It's just about to become stranger. It happens only when I clear the buffer and flip to the screen. If I just clear the buffer, all is well. If I just flip, all is well. As soon as I put both into my code, it'll run for about 4 seconds before resetting for no reason. It gets worse than resetting, however; any and all files that are open when my computer resets are corrupted. Fortunately, I had been working on a cheap little screensaver for only an hour before this started happening (this was the first day of using the computer after the updates) and didn't lose the game I've been writing for nearly 4 months. Nonetheless, I'm not pleased that I cannot develop anything reliably any more. I've tried switching RAM and re-installing DX, but neither works. I have determined that neither call, .Flip nor .BltColorFill, have had errors when they were executed. The surface was not in use, and my DX has worked fine for all my games. I'm desperately hoping that my video board is not the issue, as it would have been my third bad video board in the last two days!. Does anybody have any advice? I'd be willing to post a simple example that causes my computer to crash, if necessary. Thanks, Amrazek
Eric ColemanIf you're using Windows 2000 or XP, then you might need to turn out automatic rebooting when an error ocours. Go to the Control Panel and double click on "System", then click on the "Advanced" tab, and then the "Startup and Recovery" button. Make sure that the "automatically reboot" checkbox isn't checked. Also, is it just your program that causes your computer to reboot or is it any DirectX program?
AmrazekIt appears to be only my program; all of my DirectX games seem to be fine.
Eric ColemanWhat operating system are you using?
AmrazekMy operating system is Windows 2000, and I've got an ATI Radeon VE board. Your previous suggestion has helped me gather more data; I got a blue screen telling me of an exception error, and spewed out many memory addresses before finally getting to "DateStamp 3a95814d - ati2dvag.dll". Perhaps this DLL is at fault? I'll try to do a search on it, and hopefully find somewhere to download it, or telling me how to fix it.
AmrazekThe solution is so simple I could slap myself [B)]. The problem was that the original drivers supplied with the board were not "fully compatible" with Win2K. Thanks to a bit of digging at various forums, I was able to find an updated driver that appears to work. Thanks a lot Eric! I owe you one [;)] -Amrazek